Talk:ArmA Beta Patch 1.15

From Bohemia Interactive Community
Jump to: navigation, search

5258 - Fixed: Command line parameter -maxmem=xxx was not working on LINUX dedicated server.

But where is the Linux dedicated server download ???? --HeliJunkie 23:00, 23 December 2008 (CET)


Thanks so much for the Christmas Present BI!!

I do have a question concerning the following AWESOME addition. 5262 - New: Optional server.cfg entry timeStampFormat to specify time stamp for each line in *.rpt file. Possible values: "none", "short", "full".

I have tried all of the following:
timeStampFormat=1;
timeStampFormat=full; or timeStampFormat="full";
timeStampFormat=short; or timeStampFormat="short";

in the server.cfg and in the arma.cfg.

I have looked in the server side RPT and the client side RPT.

I cannot seem to get it working. Can you or anyone answer? Thanks in advance

--ViperMaul 23:47, 23 December 2008 (CET)

I tried timeStampFormat="full"; and timeStampFormat="short"; in the server.cfg of the dedicated server and got something like '2008/12/24, 11:23:41 ...' and '11:29:18 ...' in front of each line (not at the startup-errors/warnings) in the arma_server.rpt.
--Master85 12:16, 24 December 2008 (CET)
Hmm... I used the -cfg= startup parameter to change my default server.cfg file name. I wonder if that is the reason it is not working for me. I will try without it when I get home. Thanks for your reply.
--ViperMaul 11:25, 26 December 2008 (CET)
To change the default server.cfg file name you have to use the -config= startup parameter; -cfg= is for the basic.cfg.
--Master85 12:12, 26 December 2008 (CET)
Yes I use both -config and -cfg. But it does not work for me. Some combination is making this not work. I will have to start with a fresh default server.cfg.
--ViperMaul 07:23, 27 December 2008 (CET)


Hey I am back home from Christmas. I can now test this...

Ok I see the problem here. I was expecting a TimeStamp on every since line entry including the first few starts lines and when I didn't see them I stopped testing prematurely and said it didn't work. Here is what I saw that trigger this thought...

Exe version: Tue Dec 23 09:51:11 2008
build 1.15.5268
Item STR_03s01 listed twice File stra_debug\config.cpp, line 414: '/stra_debug/Controls/SubBackground1.style': Missing ';' at the end of line File stra_debug\config.cpp, line 423: '/stra_debug/Controls/SubBackground2.style': Missing ';' at the end of line File stra_debug\config.cpp, line 438: '/stra_debug/Controls/ValueExpression.style': Missing ';' at the end of line Conflicting addon CAWeapons in 'ca\weapons\', previous definition in 'manpad\' Updating base class ->D30, by lrd30\config.bin/cfgWeapons/LRD30/ Updating base class Turrets->, by lrd30\config.bin/cfgVehicles/D30/Turrets/ Updating base class ->D30, by lrd30\config.bin/cfgVehicles/LRD30/ Updating base class ->M119, by lrm119\config.bin/cfgWeapons/LRM119/ Updating base class Turrets->, by lrm119\config.bin/cfgVehicles/M119/Turrets/ Updating base class ->M119, by lrm119\config.bin/cfgVehicles/LRM119/ Updating base class AH6->MH6, by ru_air\config.cpp/CfgVehicles/rusMH6/ Updating base class RscText->RscPicture, by ca\ui\config.bin/CA_Mainback/ Updating base class ->CAManBase, by ca\characters\config.bin/CfgVehicles/SoldierWB/ Updating base class ->SoldierWB, by ca\characters\config.bin/CfgVehicles/SoldierWMedic/ Updating base class Tank->M113, by ca\tracked\config.bin/CfgVehicles/Vulcan/ Updating base class ->Boat, by CA\water\config.bin/CfgVehicles/RHIB/ Updating base class ->Boat, by CA\water\config.bin/CfgVehicles/Zodiac/ Updating base class ->Zodiac, by CA\water\config.bin/CfgVehicles/PBX/ Updating base class ->Truck5tMG, by ca\wheeled\config.bin/CfgVehicles/Truck5t/ Updating base class ->Extended_EventHandlers, by extended_eventhandlers\config.bin/CfgVehicles/Helicopter/EventHandlers/ 2008/12/27, 13:48:39 File description.ext, line 1: '.respawn': Missing ';' at the end of line 2008/12/27, 13:48:39 File description.ext, line 1: '.respawndelay': Missing ';' at the end of line

As you can see the following entry types are missing timeStamps.

  • "Updating base class" entries
  • "Conflicting addon" entries
  • "Item {item_type} listed twice" entries
  • "config.cpp" errors entries

I am not saying I want to pull a Dev away from Arma2 to fix this for 1.15 Beta. I just wasn't expecting the missing TimeStamps. But I can see the TimeStamps once I am in a mission and that is what is important. This can be seen once the description.ext is processed for the mission that is being run.

--ViperMaul 21:52, 27 December 2008 (CET)