Template:GVI

From Bohemia Interactive Community
Revision as of 19:44, 1 June 2018 by Lou Montana (talk | contribs) (Fix issue)
Jump to navigation Jump to search

Template GVI standing for Game Version Image.

Usage

Placing {{GVI|arma3|dev}} in a page will result in

Introduced with Arma 3 version ?dev.

being rendered in it's place.

Parameters

The template accepts three params, the third one being optional.

Game Name

The first param must be the required Game Name such as arma2 or ofp.

The text is parsed by {{Name}} so is capable of understanding many alternative inputs.

Version Number

The second param must be the required Version Number such as 0.20 or 1.82.

Categorize

The third param is optional and if included (e.g. {{GVI|ofp|1.30|cat}}), will place the page on which the this Template is used into the appropriate Category for the Game+Version.

Any value may be added as the third param, but for clarity and continuity, use something like cat, category or categorize so that future editors understand its purpose.

Examples

Any of the examples below can also include the third parameter, to place the page they're used on into the Category they link to.

Code Result
{{GVI|ofp|1.30}}
Introduced with Operation Flashpoint version ?1.30
{{GVI|ofpr|1.80}}
Introduced with Operation Flashpoint: Resistance version ?1.80
{{GVI|arma|?}}
{{GVI|arma|1.1}}
{{GVI|arma2|1.11}}
Introduced with Arma 2 version ?1.11
{{GVI|oa|1.63}}
[[File:oa version.gif|link=Category:Introduced with oa version ? 1.63|alt=Introduced with oa version ?]]1.63
{{GVI|arma2oa|1.60}}
Introduced with Arma 2: Operation Arrowhead version ?1.60
{{GVI|arma3|dev}}
Introduced with Arma 3 version ?dev.
{{GVI|arma3|0.50}}
Introduced with Arma 3 version ?0.50
{{GVI|arma3|0.58}}
Introduced with Arma 3 version ?0.58
{{GVI|arma3|0.76}}
Introduced with Arma 3 version ?0.76
{{GVI|arma3|1.22}}
Introduced with Arma 3 version ?1.22
{{GVI|tkoh|1.02}}
Introduced with Take On Helicopters version ?1.02
{{GVI|vbs1|2.12.14}}
[[File:vbs1 version.gif|link=Category:Introduced with vbs1 version ? 2.12.14|alt=Introduced with vbs1 version ?]]2.12
{{GVI|vbs2|1.49}}
[[File:vbs2 version.gif|link=Category:Introduced with vbs2 version ? 1.49|alt=Introduced with vbs2 version ?]]1.49