Talk:Java Scripting

From Bohemia Interactive Community
Jump to: navigation, search

Java SE version

Do we need the JDK or is JRE sufficient? Must we use 1.7 (current version is 7u3)?
Ceeeb 22:14, 22 February 2012 (CET)

For running Java scripts you need nothing but the updated game (it has its own JRE distributed with it). For development of scripts the JDK is needed (to compile the classes), and BI is using 1.7 to base its work on currently. -Joris 09:35, 23 February 2012 (CET)
Damn, I only installed JRE. I was reading a Eclipse tutorial and it mentioned: "Eclipse contains its own development tools, e.g. Java compiler. --- The JDK is required if you compile Java source code outside Eclipse and for advanced development scenarios."
'Take On World!' sample seemed to work but am I gonna run into problems later? --Rok 12:48, 23 February 2012 (CET)
If you're able to compile using just the JRE and Eclipse, you're good to go. -Joris 09:19, 24 February 2012 (CET)