Scripting: Best Practices – Arma Reforger

From Bohemia Interactive Community
Jump to navigation Jump to search
m (Text replacement - "\[ *((ftp|http)s?:\/\/[^ ]+) +([^ =]+) *\]" to "{{Link|$1|$3}}")
(Add more examples)
Line 1: Line 1:
{{TOC|side}}
{{TOC|side}}
== Getting started ==
== Getting Started ==


In the domain of development, any rule is a rule of thumb. If a rule states for example that it is better that a line of code doesn't go over 80 characters, it doesn't mean that any line '''''must not''''' go over 80 characters; sometimes, the situation needs it.
In the domain of development, any rule is a rule of thumb.
If a rule states for example that it is better that a line of code doesn't go over 80 characters, it doesn't mean that any line '''''must not''''' go over 80 characters; sometimes, the situation needs it.


If the code has a good structure, '''do not''' change it to enforce a single arbitrary rule. If many of them are not implemented/not respected, changes should be applied; again, this is according to one's judgement.
If the code has a good structure, '''do not''' change it to enforce a single arbitrary rule. If many of them are not implemented/not respected, changes should be applied; again, this is according to one's judgement.
Line 9: Line 10:




== Best practices ==
== Best Practices ==


=== Code format ===
=== Code Format ===
<!--
<!--
See Scripting Guidelines / Conventions for all the conventions to date.
See Scripting Guidelines / Conventions for all the conventions to date.
Line 21: Line 22:
** it also hinders debugger's usage, e.g in the event of an inlined {{hl|if}}
** it also hinders debugger's usage, e.g in the event of an inlined {{hl|if}}


=== Variable format ===
=== Variable Format ===
<!--
<!--
See Scripting Guidelines / Conventions for all the conventions to date.
See Scripting Guidelines / Conventions for all the conventions to date.
Line 27: Line 28:


* Name variables and functions properly: code must be readable by a human being, e.g variables like '''u''' instead of '''uniform''' should not exist.
* Name variables and functions properly: code must be readable by a human being, e.g variables like '''u''' instead of '''uniform''' should not exist.
** '''i''' is an accepted iteration variable name (e.g in {{hl|for}} loops).
** '''{{hl|i}}''' is an accepted iteration variable name (e.g in {{hl|for}} loops).
* Prefix any public content (classes, global methods, global variables) with a [[OFPEC tags|Creator Tag]] in order to prevent conflicts with other mods.
* Prefix any public content (classes, global methods, global variables) with a [[OFPEC tags|Creator Tag]] in order to prevent conflicts with other mods.
* Use the closest value type whenever possible; using {{hl|auto}} for a known variable type makes code less clear.
* Use the closest value type whenever possible; using {{hl|auto}} for a known variable type makes code less clear.
Line 48: Line 49:


==== Examples ====
==== Examples ====
{| class="wikitable"
{| class="wikitable valign-top"
! Improvable
! Improvable
! Good
! Good
|- style="vertical-align: top"
 
|-
| <enforce>
| <enforce>
auto number = 42;
auto number = 42;
Line 60: Line 62:
Dog cutePet = new Dog();
Dog cutePet = new Dog();
</enforce>
</enforce>
|- style="vertical-align: top"
 
|-
| <enforce>
// a method call is more expensive than a bool check
if (obj.MustBeTreated() || m_bTreatAllObjects)
Print(obj);
 
if (obj.MustBeTreated() && m_bTreatAllObjects)
Print(obj);
</enforce>
| <enforce>
// cheap checks go first, expensive checks (method calls) go after
if (m_bTreatAllObjects || obj.MustBeTreated())
Print(obj);
 
if (m_bTreatAllObjects && obj.MustBeTreated())
Print(obj);
</enforce>
 
|-
| <enforce>
// many identical method calls
if (obj.MustBeTreated() && obj.GetObject() != null)
Print("Result: " + obj.GetObject().m_sValue1 + " " + obj.GetObject().m_sValue2);
</enforce>
| <enforce>
| <enforce>
for (int i = 0; i < list.Count(); i++)
// "bigger", non-repetitive code can be beneficial for performance and readability
if (obj.MustBeTreated())
{
{
SCR_Object subObj = obj.GetObject();
if (subObj)
Print("Result: " + subObj.m_sValue1 + " " + subObj.m_sValue2);
}
</enforce>
|-
| <enforce>
foreach (SCR_Object obj : list)
{
Method(obj); // one method call per iteration
}
void Method(SCR_Object obj)
{
if (!obj)
return;
Print(obj.m_sName + " has a value of " + obj.m_sValue);
}
</enforce>
| <enforce>
foreach (SCR_Object obj : list) // the least method calls, the better
{
if (!obj)
continue;
Print(obj.m_sName + " has a value of " + obj.m_sValue);
}
</enforce>
|-
| <enforce>
for (int i = 0; i < list.Count(); i++) // list.Count() is called on every iteration
{
// ...
}
}
</enforce>
</enforce>
Line 69: Line 132:
for (int i = 0, count = list.Count(); i < count; i++) // only one list.Count() call
for (int i = 0, count = list.Count(); i < count; i++) // only one list.Count() call
{
{
// ...
}
}
</enforce>
</enforce>


<!--
|-
| <enforce>
for (int i, count = list.Count(); i < count; i++)
{
if (list[i]) // first
Print(list[i]); // and second .Get(i) method calls
}
</enforce>
| <enforce>
foreach (SCR_Object obj : list) // foreach is faster for start-to-end iterating
{
if (obj)
Print(obj); // no additional method call
}
</enforce>


|- style="vertical-align: top"
|-
| <enforce>
| <enforce>
// declaring 'text' string in every for loop creates a pointer attribution for each loop
// declaring an 'obj' every loop generates a pointer release each time
for (int i = 0, count = list.Count(); i < count; i++)
for (int i = 0, count = list.Count(); i < count; i++)
{
{
string text = "Value " + i + " is " + list[i];
SCR_Object obj = list[i].m_Object;
Print(text);
if (obj)
Print(obj.m_sName);
}
}
</enforce>
</enforce>
| <enforce>
| <enforce>
string text; // external declaration = one pointer attribution
SCR_Object obj; // external declaration = only one release
for (int i = 0, count = list.Count(); i < count; i++)
for (int i = 0, count = list.Count(); i < count; i++)
{
{
text = "Value " + i + " is " + list[i];
obj = list[i].m_Object;
Print(text);
if (obj)
Print(obj.m_sName);
}
</enforce>
 
|-
| <enforce>
array<SCR_Object> toRemove = {};
foreach (SCR_Object obj : bigArray)
{
if (obj.m_bShouldBeRemoved)
toRemove.Insert(obj);
}
 
foreach (SCR_Object obj : toRemove)
{
bigArray.RemoveItem(obj);
}
}
</enforce>
</enforce>
which can also be simplified to
| <enforce>
<enforce>
for (int i = bigArray.Count() - 1; i >= 0; i--) // reverse iterating
foreach (int i, element : list)
{
{
PrintFormat("Value %1 is %2", i, element);
if (bigArray[i].m_bShouldBeRemoved)
bigArray.Remove(i);
}
}
</enforce>
</enforce>


-->
|-
 
|- style="vertical-align: top"
| <enforce>
| <enforce>
if (a)
if (a)
Line 108: Line 201:
{
{
if (c)
if (c)
{
Method(true);
Method(true);
}
else
else
{
Method(false);
Method(false);
}
}
}
}
}
Line 120: Line 209:
| <enforce>
| <enforce>
if (a && b)
if (a && b)
{
Method(c);
Method(c);
}
</enforce>
</enforce>
|- style="vertical-align: top"
 
| Boilerplate code:
|-
<enforce>
| <enforce>
int i = 0;
int i = 0;
if (a)
if (a)
{
i++;
i++;
}
 
if (b)
if (b)
{
i++;
i++;
}
 
if (c)
if (c)
{
i++;
i++;
}
</enforce>
</enforce>
| Simplified:
| <enforce>
<enforce>
int i = 0;
int i = 0;
array<bool> conditions = { a, b, c };
array<bool> conditions = { a, b, c };
Line 151: Line 233:
}
}
</enforce>
</enforce>
or (if some other code is involved)
 
<enforce>
|-
int i = 0;
IncrementIfTrue(a, i);
IncrementIfTrue(b, i);
IncrementIfTrue(c, i);
void IncrementIfTrue(bool condition, out int value)
{
if (condition)
value++;
}
</enforce>
|- style="vertical-align: top"
| <enforce>
| <enforce>
Initialise(player1, 1);
Initialise(player1, 1);
Line 183: Line 253:


==== Code Comments ====
==== Code Comments ====
Code comments are surprisingly '''not''' a must-have; code organisation combined to variable names should be enough to be read by a human, '''then''' comment can be used:
Code comments are surprisingly '''not''' a must-have for inside code; code organisation combined to variable names should be enough to be read by a human, '''then''' comment can be used:
** a comment should explain '''''why''''' the code is written this way
* a comment should explain '''''why''''' the code is written this way
** a comment should not tell '''''what''''' the code does; code should be self-explanatory
* a comment should not tell '''''what''''' the code does; code should be self-explanatory
** as a last resort in the event of a complex piece of code, a comment can be used to describe what the code actually does - or at least its intention
* as a last resort in the event of a complex piece of code, a comment can be used to describe what the code actually does - or at least its intention
*On the other hand, Documentation is more than welcome as it provides information from the outside without having to read the code. Enfusion uses {{Link|https://www.doxygen.nl/manual/docblocks.html|Doxygen}} format.
 
On the other hand, ''documentation'' is more than welcome as it provides information from the outside without having to read the code. Enfusion uses {{Link|Doxygen}}.


==== Files organisation ====
==== Files Organisation ====
{{Feature|informative|See [[Arma Reforger:Directory Structure|Directory Structure]] to know how/where to organise script files (Scripts\GameCode).}}
{{Feature|informative|See [[Arma Reforger:Directory Structure|Directory Structure]] to know how/where to organise script files (Scripts\GameCode).}}


* Have one class/enum per file
* Have one class/enum per file
** Small classes/enums can always be grouped together in the same file, provided they are part of the same system or only used there
** Small classes/enums can always be grouped together in the same file, provided they are part of the same system or only used there
* Use (sub-)directories to group related classes
* Use (sub-)directories to group related classes together




{{GameCategory|armaR|Modding|Guidelines|Scripting}}
{{GameCategory|armaR|Modding|Guidelines|Scripting}}

Revision as of 08:46, 21 September 2023

Getting Started

In the domain of development, any rule is a rule of thumb. If a rule states for example that it is better that a line of code doesn't go over 80 characters, it doesn't mean that any line must not go over 80 characters; sometimes, the situation needs it.

If the code has a good structure, do not change it to enforce a single arbitrary rule. If many of them are not implemented/not respected, changes should be applied; again, this is according to one's judgement.

With that being said, let's go!


Best Practices

Code Format

  • Reminder: chosen indentation for Enfusion is Allman style
  • Reminder: indentation is done with tabulations
  • Use empty space. Line return, spaces before and after brackets, if this improves readability, use it: space is free
  • One-lining (putting everything in one statement) memory improvement is most of the time not worth the headache it gives when trying to read it: don't overuse it
    • it also hinders debugger's usage, e.g in the event of an inlined if

Variable Format

  • Name variables and functions properly: code must be readable by a human being, e.g variables like u instead of uniform should not exist.
    • i is an accepted iteration variable name (e.g in for loops).
  • Prefix any public content (classes, global methods, global variables) with a Creator Tag in order to prevent conflicts with other mods.
  • Use the closest value type whenever possible; using auto for a known variable type makes code less clear.

Code Structuration

SOLID

A series of development principles to follow in order to ensure an easy code maintenance and lifetime.

See SOLID.

DRY

Don't Repeat Yourself. If within the same class, the same code or the same pattern is written in various places, write a protected method and use appropriate parameters.

Logical Simplifications

If the code has too many repetitions, make a common method as stated above.

If the code has too many levels, it is time to split it and rethink it.

Examples

Improvable Good
auto number = 42; Animal cutePet = new Dog();
int number = 42; Dog cutePet = new Dog();
// a method call is more expensive than a bool check if (obj.MustBeTreated() || m_bTreatAllObjects) Print(obj); if (obj.MustBeTreated() && m_bTreatAllObjects) Print(obj);
// cheap checks go first, expensive checks (method calls) go after if (m_bTreatAllObjects || obj.MustBeTreated()) Print(obj); if (m_bTreatAllObjects && obj.MustBeTreated()) Print(obj);
// many identical method calls if (obj.MustBeTreated() && obj.GetObject() != null) Print("Result: " + obj.GetObject().m_sValue1 + " " + obj.GetObject().m_sValue2);
// "bigger", non-repetitive code can be beneficial for performance and readability if (obj.MustBeTreated()) { SCR_Object subObj = obj.GetObject(); if (subObj) Print("Result: " + subObj.m_sValue1 + " " + subObj.m_sValue2); }
foreach (SCR_Object obj : list) { Method(obj); // one method call per iteration } void Method(SCR_Object obj) { if (!obj) return; Print(obj.m_sName + " has a value of " + obj.m_sValue); }
foreach (SCR_Object obj : list) // the least method calls, the better { if (!obj) continue; Print(obj.m_sName + " has a value of " + obj.m_sValue); }
for (int i = 0; i < list.Count(); i++) // list.Count() is called on every iteration { // ... }
for (int i = 0, count = list.Count(); i < count; i++) // only one list.Count() call { // ... }
for (int i, count = list.Count(); i < count; i++) { if (list[i]) // first Print(list[i]); // and second .Get(i) method calls }
foreach (SCR_Object obj : list) // foreach is faster for start-to-end iterating { if (obj) Print(obj); // no additional method call }
// declaring an 'obj' every loop generates a pointer release each time for (int i = 0, count = list.Count(); i < count; i++) { SCR_Object obj = list[i].m_Object; if (obj) Print(obj.m_sName); }
SCR_Object obj; // external declaration = only one release for (int i = 0, count = list.Count(); i < count; i++) { obj = list[i].m_Object; if (obj) Print(obj.m_sName); }
array<SCR_Object> toRemove = {}; foreach (SCR_Object obj : bigArray) { if (obj.m_bShouldBeRemoved) toRemove.Insert(obj); } foreach (SCR_Object obj : toRemove) { bigArray.RemoveItem(obj); }
for (int i = bigArray.Count() - 1; i >= 0; i--) // reverse iterating { if (bigArray[i].m_bShouldBeRemoved) bigArray.Remove(i); }
if (a) { if (b) { if (c) Method(true); else Method(false); } }
if (a && b) Method(c);
int i = 0; if (a) i++; if (b) i++; if (c) i++;
int i = 0; array<bool> conditions = { a, b, c }; foreach (bool condition : conditions) { if (condition) i++; }
Initialise(player1, 1); Initialise(player2, 2); Initialise(player3, 3); Initialise(player4, 4); Initialise(player5, 5); Initialise(player6, 6);
array<IEntity> list = { player1, player2, player3, player4, player5, player6 }; foreach (int i, item : list) { Initialise(item, i + 1); }

Code Comments

Code comments are surprisingly not a must-have for inside code; code organisation combined to variable names should be enough to be read by a human, then comment can be used:

  • a comment should explain why the code is written this way
  • a comment should not tell what the code does; code should be self-explanatory
  • as a last resort in the event of a complex piece of code, a comment can be used to describe what the code actually does - or at least its intention

On the other hand, documentation is more than welcome as it provides information from the outside without having to read the code. Enfusion uses Doxygen.

Files Organisation

See Directory Structure to know how/where to organise script files (Scripts\GameCode).
  • Have one class/enum per file
    • Small classes/enums can always be grouped together in the same file, provided they are part of the same system or only used there
  • Use (sub-)directories to group related classes together