Operation Flashpoint: Troubleshooting

From Bohemia Interactive Community
Jump to navigation Jump to search


Troubleshooting FAQ

This article's main purpose is to document common problems and solutions to fix those problems in OFP. If none of the problems here describe your situation then please check the BI forums or a good starting point would be to visit The Avon Lady's OFP FAQ, where you can find a list of problems and fixes that cover a wide range of topics.

System Drivers

Stay current! Make sure you have the most recent drivers available for your hardware. Older drivers often contain bugs and can cause various performance issues and bugs while playing the game. Hardware manufacturers often work to improve performance through driver updates.


Note: you may need to reinstall DirectX even if you already have 9.0c or Windows Vista - the most recent DirectX 9.0c release is from December 2006.




CD Key Location

The CD key is listed on the last page of the instruction booklet included with the game.

Strange Error Messages, Corrupted Installation

When running OFP, I am getting strange error messages like: "No entry config.bin::CfgWorlds" or I am getting other strange errors.


You can verify your installation using the OFPCheck utility available here. If any files are indicated to be corrupted, follow step-by-step list of things to do included in file OFPCheck.txt file.

Note: The most common cause of data corruption is a bug in some VIA chipset based motherboards. If you are using such motherboard, check VIA other related topics in this forum section, like VIA Chipset Problems.

Patches & Updates

Patches and updates for Operation FlashPoint can be obtained here on the Operation Flashpoint website.

The following is a patch & upgrade path for Operation Flashpoint.

Patches and Upgrades can be found here BIS Updates

I have Operation Flashpoint: GOTY edition or Resistance upgraded to version 1.91:

  • Resistance and GOTY edition patch 1.91 to 1.96

I have Operation Flashpoint: GOTY edition:

  • GOTY edition patch 1.96

I have Operation Flashpoint: RESISTANCE:

  • Resistance Patch 1.96

I have Operation Flashpoint: GOLD edition:

  • Patch 1.46

I have version 1.20(US):

  • Ultimate upgrade 3 (v1.30) > Patch 1.46

I have version 1.00 (EU):

  • Ultimate upgrade 2 (v1.20) > Ultimate upgrade 3 (v1.30) > Patch 1.46

Patch install, corrupt files

Why cannot I apply patch when I have some files corrupted?


To keep patch size as small as possible, patch uses as much data from original version as possible (this is called incremental patching). If we would allow applying patch to corrupted data, the patch result could be even more corrupted than current data you have. For correct patching it is critical that you have all files in the same state as they were distributed.

If you have some files corrupted, you may easily encounter random crashes in different parts of the game, therefore you should try to fix the problems leading to data corruption before you apply patch.

Different sources of corrupted data may be:

(1) Faulty hard disc controller or hard disc

If you have VIA chipset, you may be affected by known bug in IDE channel controller. See above for possible solutions.

(2) Physically bad CD

In this case you should get your CD replaced for free in the shop where you bought it (in most countries law gurantees you at least six moths for replacement of faulty material)

(3) Unreliable CD ROM drive

Some CD ROM drives are unreliable. Copying dammaged file several times from your CD and trying running patch after each attempt you may (with a little luck) repair your files. You can also use our Installation Verification utility, that comes with a step-by-step lists of things to do in this case. If you have unreliable CD ROM drive, you might want to consider buying a new one or borrowing it from a friend just to install the game.

(4) Faulty hard disc surface

Hard discs sometimes (very rarely) fail. To check if your disc is healthy, run some Disk checking utility with "Scan for bad sectors" enabled.

Patch install 1.20, Error found in file DTA\Sound.pbo

When I try to install patch 1.20, I get error message like "Error found in file DTA\Sound.pbo (2e091cb6!=6c2ebbc9)". I am unable to install the patch.


The problem is caused by corrupted data already stored on your hard disc. If you have a VIA chipset, this may be caused by bug in VIA drivers / chipset. Disabling DMA for both hard drive and CD ROM often fixes the problem. See also VIA Chipset Problems for more information about VIA chipset problems. If you have other chipset than VIA, reinstalling game should help. If not, you should probably ask for replacement disc, as your media seems to be corrupted.

Original CD not in drive.(while patching)

If I try to install a patch, I receive the message "Original CD not in drive" or "Please insert the correct CD-ROM, select OK and restart application." will appear. I have the Original CD in the drive.


Please download Ultimate Upgrade from here If it doesn't help please contact Codemasters support. Codemasters Support

Graphical Issues

Cannot Create 3D

I cannot start Operation Flashpoint due to error message "Cannot create 3D..." I have GeForce and latest drivers. I'm using 16 bit color depth.


The following steps may help:

(1) If you have nVidia TnT or GeForce / GeForce 2 card and you are running in 16-bit mode, you must check in D3D settings "Adjust Z-buffer depth to match render buffer depth". "Adjust Z-buffer depth ..." option can be found this way:

Right click on desktop >Properties >Settings >Advanced > GeForce bookmark >Additional Properties > Direct3D setting.

(2) Select a lower resolution. This may help especially if you have graphics card with 8Mb or 16 Mb of RAM.

(3) Edit line "refresh=;" to "refresh=0;" or "refresh=60;" in your Flashpoint.cfg. If there is no such line, then add it.

(4) Test DirectX 8: Run DxDiag and perform Direct3D test. If anything is reported as not working, reinstall DirectX and/or graphics card drivers.

(5) If none of above helped, please contact technical support (support@bistudio.com)

(6) Try adding the -nomap extension to your startup shortcut.

Textures Are White

When Operation Flashpoint is started some of the textures on vehicles or ground are white.


Install the latest graphic card driver on your system.

Disable multitexturing in ingame video options.

If only the Island's textures are white, recopy the Island PBO's (Abel, Noe, Eden and Cain) from your CD. Note that the island consists of a .WRP and .PBO. The PBO contains textures and the such.

Flickering Shadows ATI GFX Adapter

In game shadows on objects and/or roads are flickering badly. I have a ATI Radeon 9500/9700 graphics card.


This problems is caused by a bug in many older ATI drivers.

To fix it download ATI Catalyst 3.1 or newer driver from ATI Web Site.

If you do not want to update your drivers, you can also disable HW T&L (use slower plain Direct3D device) as a workaround.

Slow Peformance

I play Resistance on high detail terrain and visibility of about 2500m - which should be of no problem, as I'm playing on very powerful computer. Still performance seems to be very slow, especially in some missions. What can I do?


Use lower terrain detail settings (like "Normal"), especially when using increased viewing distance. Terrain detail level "High" requires a lot of memory and CPU resources, and it was included mostly in anticipation of hardware that will be available several years from now.

VIA Chipset Problems

Operation Flashpoint often randomly crashes. I have Via chipset and AGP 4x


Setting AGP speed to 1x or 2x often helps. If you have AMD processor, you can also check this link to Microsoft's Knowledge Base

Following troubleshooting guide was compiled by Ravefree:

1. Use the LoadMinimum registry fix listed on AMD's site under patches
2. Install latest VIA chip set drivers
3. If possible reserve an IRQ setting for your video card (Geforce)
4. Make sure your computer has proper ventalation and cooling
5. Check power supply for higher end systems a 350+ or 400 watt power supply is a must have...
6. If your BIOS supports it, find out what the recommended PCI latency should be set to
7. Try lowering the AGP from 4x to 2x, to 1x if problems continue


Default Addons List

Cold War Crisis



KOLO.PBO 	OFP: Resistance patch 1.85
MINI.PBO 	OFP: Resistance patch 1.85
NOE.PBO 	OFP: Resistance
O_WP.PBO 	OFP: Resistance patch 1.85
O.PBO 		OFP: Resistance

Game of the Year Edition (GOTY)


Addons At Ease

BISCamel.pbo 	Sopwith Camel 

Red Hammer Campaign


Mouse Issues

Double Cursors

Two mouse cursors are visible in the game. One classic Windows mouse and the second is the ingame mouse.


Alt + Tabbing to Windows and then back to the game corrects the problem.

Many users report this problem can be solved by installing latest video card drivers.

It also seems this problem can be solved by selecting different resolutions for the game and the Windows desktop.

Laggy Mouse

The mouse cursor appears to be laggy, it moves a little after I moved the mouse.


Try to use a lower resolution, your computer may not be powerful enough to support such resolution.

Mouse not Responding

I see game screen, but mouse cursor doesn't move when I moved the mouse and I can't use keyboard too.


Sometimes press Alt + Tabbing. After each pressing try if is mouse function.

Sound Issues

SoundBlaster+686b Southbridge Chipset

I am having trouble with a system using a VIA chipset including a 686b southbridge and a Creative Sound Blaster Live card.


When the 686b southbridge was first released, motherboard manufacturers and VIA discovered a problem when trying to transfer files between the primary and the secondary IDE channels on motherboards using ultra-DMA, when a Sound Blaster Live was plugged in and drivers activated. This issue was caused because too much noise is transferred across the PCI bus by the Sound Blaster Live driver set. In an attempt to fix this issue, some motherboard manufacturers modified their BIOS. In some instances, these modifications to the BIOS caused a data corruption error even when not using a Sound Blaster Live. VIA released a patch which resolves this issue, which is incoroporated in the 4in1 drivers from the 4.31 version onwards. Motherboard manufacturers were advised to change the modifications made to thier BIOS to elimate the data corruption issue.

If you are experiencing data corruption or lock up when transferring files between two IDE drives:

1) Make sure you have the latest BIOS from your motherboard manufacturer.

2) Make sure you have the latest 4in1 drivers

3) Make sure when you set up your system that you install the 4in1 drivers both before and after you install the SBL to make sure that the drivers see your SBL and install the correct patch. The patch will only install if the SBL is installed.

For more information about possible data corruption on VIA based motherboards visit VIA web site.