Difference between revisions of "Template:GVI"

From Bohemia Interactive Community
Jump to navigation Jump to search
(New way to handle Game Version Images. Not complete before image uploads and thorough testing is done)
 
m (Usage layout)
Line 24: Line 24:
  
 
<tt><nowiki>{{GVI|ofp|1.30}}</nowiki></tt> makes {{GVI|ofp|1.30}}
 
<tt><nowiki>{{GVI|ofp|1.30}}</nowiki></tt> makes {{GVI|ofp|1.30}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|ofpr|1.80}}</nowiki></tt> makes {{GVI|ofpr|1.80}}
 
<tt><nowiki>{{GVI|ofpr|1.80}}</nowiki></tt> makes {{GVI|ofpr|1.80}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|arma|?}}</nowiki></tt> makes {{GVI|arma|?}}
 
<tt><nowiki>{{GVI|arma|?}}</nowiki></tt> makes {{GVI|arma|?}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|arma|1.11}}</nowiki></tt> makes {{GVI|arma|1.11}}
 
<tt><nowiki>{{GVI|arma|1.11}}</nowiki></tt> makes {{GVI|arma|1.11}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|arma2|1.11}}</nowiki></tt> makes {{GVI|arma2|1.11}}
 
<tt><nowiki>{{GVI|arma2|1.11}}</nowiki></tt> makes {{GVI|arma2|1.11}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|oa|1.63}}</nowiki></tt> makes {{GVI|oa|1.63}}
 
<tt><nowiki>{{GVI|oa|1.63}}</nowiki></tt> makes {{GVI|oa|1.63}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|arma3|0.58}}</nowiki></tt> makes {{GVI|arma3|0.58}}
 
<tt><nowiki>{{GVI|arma3|0.58}}</nowiki></tt> makes {{GVI|arma3|0.58}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|arma3|0.76}}</nowiki></tt> makes {{GVI|arma3|0.76}}
 
<tt><nowiki>{{GVI|arma3|0.76}}</nowiki></tt> makes {{GVI|arma3|0.76}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|arma3|1.22}}</nowiki></tt> makes {{GVI|arma3|1.22}}
 
<tt><nowiki>{{GVI|arma3|1.22}}</nowiki></tt> makes {{GVI|arma3|1.22}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|tkoh|1.02}}</nowiki></tt> makes {{GVI|tkoh|1.02}}
 
<tt><nowiki>{{GVI|tkoh|1.02}}</nowiki></tt> makes {{GVI|tkoh|1.02}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|vbs1|2.12.14}}</nowiki></tt> makes {{GVI|vbs1|2.12.14}}
 
<tt><nowiki>{{GVI|vbs1|2.12.14}}</nowiki></tt> makes {{GVI|vbs1|2.12.14}}
 
+
{{Clear}}
 
<tt><nowiki>{{GVI|vbs2|1.49}}</nowiki></tt> makes {{GVI|vbs2|1.49}}
 
<tt><nowiki>{{GVI|vbs2|1.49}}</nowiki></tt> makes {{GVI|vbs2|1.49}}
  

Revision as of 20:16, 28 May 2014

Template GVI standing for Game Version Image.

Usage

Placing {{GVI|arma3|dev}} in a page will result in

Introduced with Arma 3 version ? dev

being rendered in it's place.

Parameters

The template accepts 3 params, the 3rd of which is optional.

Game Name

The first param must be the required Game Name such as arma2 or ofp.

The text is parsed by {{Name}} so is capable of understanding many alternative inputs.

Version Number

The second param must be the required Version Number such as 0.20 or 1.82.

Categorize

The third param is optional and if included (e.g. {{GVI|ofp|1.30|cat}}), will place the page on which the this Template is used into the appropriate Category for the Game+Version.

Any value may be added as the third param, but for clarity and continuity, use something like cat, category or categorize so that future editors understand its purpose.

Examples

Any of the examples below can also include the third parameter, to place the page they're used on into the Category they link to.

{{GVI|ofp|1.30}} makes

Introduced with Operation Flashpoint version ? 1.30

{{GVI|ofpr|1.80}} makes

Introduced with Operation Flashpoint: Resistance version ? 1.80

{{GVI|arma|?}} makes

{{GVI|arma|1.11}} makes

{{GVI|arma2|1.11}} makes

Introduced with Arma 2 version ? 1.11

{{GVI|oa|1.63}} makes

[[File:oa version.gif|link=Category:Introduced with oa version ? 1.63|alt=Introduced with oa version ?]] 1.63

{{GVI|arma3|0.58}} makes

Introduced with Arma 3 version ? 0.58

{{GVI|arma3|0.76}} makes

Introduced with Arma 3 version ? 0.76

{{GVI|arma3|1.22}} makes

Introduced with Arma 3 version ? 1.22

{{GVI|tkoh|1.02}} makes

Introduced with Take On Helicopters version ? 1.02

{{GVI|vbs1|2.12.14}} makes

[[File:vbs1 version.gif|link=Category:Introduced with vbs1 version ? 2.12.14|alt=Introduced with vbs1 version ?]] 2.12.14

{{GVI|vbs2|1.49}} makes

[[File:vbs2 version.gif|link=Category:Introduced with vbs2 version ? 1.49|alt=Introduced with vbs2 version ?]] 1.49